navigation bar left navigation bar right

Secunia CSI7
navigation left tab Advisories navigation right tab
navigation left tab Research navigation right tab
navigation left tab Forums navigation right tab
navigation left tab Create Profile navigation right tab
navigation left tab Our Commitment navigation right tab
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: PSI Scanner not working

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
WolverineSix PSI Scanner not working
Member 30th Apr, 2011 08:12
Ranking: 6
Posts: 4
User Since: 28th Apr, 2011
System Score: N/A
Location: US
I recently noticed that the Secunia PSI is no longer completing scans .
IT starts then goes from step 2 to 7 then says scan aborted .
I have removed and reinstalled it several times no luck, updated it to the latest version no change .
I run Windows 7 64 bit ,16 gigs RAM,Intel I7 980 CPU 3.33MH. IE 9.Kaspersky AV,Comodo Firewall .
I moved Secunias servers to safe zone and allowed cookies and pop ups ,just in case .
This is the error message i get on the psialog
"04/29 22:41:11.075] Error while checking in with server (12045) : "The certificate authority is invalid or incorrect""
PSI is listed as a trusted app in Kaspersky and as a trusted app for my Comodo firewall
I have used PSI on other computers for years and on this one for about 4 months with no problems until now
I have it set to no longer check for publishers certificate or server certificate revocation .
I hope someone can help me with this as i am uneasy with the lack of certificate protection .and lack of update on my programs .
Below is the complete log .


[04/29 22:41:09.421] Error while checking in with server (12045) : "The certificate authority is invalid or incorrect"
[04/29 22:41:09.421] -- Program options --
[04/29 22:41:09.421] Version 0
[04/29 22:41:09.421] LogLevel 2
[04/29 22:41:09.421] Help 0
[04/29 22:41:09.421] CLI 0
[04/29 22:41:09.421] CLICLI 0
[04/29 22:41:09.421] Foreground 0
[04/29 22:41:09.421] InstallService 0
[04/29 22:41:09.421] StartService 1
[04/29 22:41:09.421] RemoveService 0
[04/29 22:41:09.421] RunAsUser
[04/29 22:41:09.421] RunAsPass <Not Set>
[04/29 22:41:09.421] RunAsLocalSystem 0
[04/29 22:41:09.421] DontWriteRegistry 0
[04/29 22:41:09.421] Network Appliance 0
[04/29 22:41:09.421] GUID
[04/29 22:41:09.421] -- Scan options --
[04/29 22:41:09.421] ScanType 1
[04/29 22:41:09.421] CheckWinUpdates 1
[04/29 22:41:09.421] -- Service options --
[04/29 22:41:09.421] CheckInInterval 60
[04/29 22:41:09.421] RequestTimeout 120
[04/29 22:41:09.421] -- Customer Area options --
[04/29 22:41:09.421] GroupName
[04/29 22:41:09.421] CAUser 001c5WY1pZf4f5ebd31141d42c811d79xxxxxxxxxxxxxxxxxx xxxxxxxxxxxxxx
[04/29 22:41:09.421] -- Internal variables --
[04/29 22:41:09.421] BinPath H:\Program Files (x86)\Secunia\PSI\PSIA.exe
[04/29 22:41:09.421] BinDir H:\Program Files (x86)\Secunia\PSI
[04/29 22:41:09.421] API_SERVER_HOST psi.secunia.com
[04/29 22:41:09.421] API_SERVER_PORT 443
[04/29 22:41:09.421] API_BASE_URI /psi_api/2003/?
[04/29 22:41:09.421] APPNAME Secunia PSI Agent
[04/29 22:41:09.421] BINNAME psi.exe
[04/29 22:41:09.421] REG_KEY_PATH SOFTWARE\Secunia\PSIA
[04/29 22:41:09.421] RegConfKey HKEY_LOCAL_MACHINE
[04/29 22:41:09.421] Version
[04/29 22:41:09.421] ComputerName MAIN
[04/29 22:41:09.421] LanGroup WORKGROUP
[04/29 22:41:09.421] CurrentUser SYSTEM
[04/29 22:41:09.421] UserPrincipalName
[04/29 22:41:09.421] LogFile H:\Program Files (x86)\Secunia\PSI\psialog.txt
[04/29 22:41:09.421] LogFileMax 2097152
[04/29 22:41:09.421] OptionMask 1024
[04/29 22:41:09.421] LastCheckIn 04/29/11 22:41:08
[04/29 22:41:09.421] NextInspection 04/29/11 22:23:03
[04/29 22:41:09.421] ServerTime 01/01/80 00:00:00
[04/29 22:41:09.421] Unknown name in invoke:notifyCheckin
[04/29 22:41:09.421] Unknown name in invoke:periodic
[04/29 22:41:10.045] Checking in with server (psi.secunia.com)
[04/29 22:41:10.045] Checkin reason : appmon
[04/29 22:41:10.045] Connecting to psi.secunia.com:443
[04/29 22:41:10.045] GET /psi_api/2003/?type=agent_check&agent_version=&tz= 25200&fm=0x80000000&uid=001c5WY1pZf4f5ebd31141d42c 811d79xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx&ui=agent&la ngroup=WORKGROUP&host=MAIN
[04/29 22:41:10.045] Request timeouts : 60000ms, 30000ms, 30000ms
[04/29 22:41:10.654] Error in HttpRequest: status=499, statusText='The certificate authority is invalid or incorrect
',winCode=12045
[04/29 22:41:11.075] Error while checking in with server (12045) : "The certificate authority is invalid or incorrect"
[04/29 22:41:11.075] -- Program options --
[04/29 22:41:11.075] Version 0
[04/29 22:41:11.075] LogLevel 2
[04/29 22:41:11.075] Help 0
[04/29 22:41:11.075] CLI 0
[04/29 22:41:11.075] CLICLI 0
[04/29 22:41:11.075] Foreground 0
[04/29 22:41:11.075] InstallService 0
[04/29 22:41:11.075] StartService 1
[04/29 22:41:11.075] RemoveService 0
[04/29 22:41:11.075] RunAsUser
[04/29 22:41:11.075] RunAsPass <Not Set>
[04/29 22:41:11.075] RunAsLocalSystem 0
[04/29 22:41:11.075] DontWriteRegistry 0
[04/29 22:41:11.075] Network Appliance 0
[04/29 22:41:11.075] GUID
[04/29 22:41:11.075] -- Scan options --
[04/29 22:41:11.075] ScanType 1
[04/29 22:41:11.075] CheckWinUpdates 1
[04/29 22:41:11.075] -- Service options --
[04/29 22:41:11.075] CheckInInterval 60
[04/29 22:41:11.075] RequestTimeout 120
[04/29 22:41:11.075] -- Customer Area options --
[04/29 22:41:11.075] GroupName
[04/29 22:41:11.075] CAUser 001c5WY1pZf4f5ebd31141d42c811d79xxxxxxxxxxxxxxxxxx xxxxxxxxxxxxxx
[04/29 22:41:11.075] -- Internal variables --
[04/29 22:41:11.075] BinPath H:\Program Files (x86)\Secunia\PSI\PSIA.exe
[04/29 22:41:11.075] BinDir H:\Program Files (x86)\Secunia\PSI
[04/29 22:41:11.075] API_SERVER_HOST psi.secunia.com
[04/29 22:41:11.075] API_SERVER_PORT 443
[04/29 22:41:11.075] API_BASE_URI /psi_api/2003/?
[04/29 22:41:11.075] APPNAME Secunia PSI Agent
[04/29 22:41:11.075] BINNAME psi.exe
[04/29 22:41:11.075] REG_KEY_PATH SOFTWARE\Secunia\PSIA
[04/29 22:41:11.075] RegConfKey HKEY_LOCAL_MACHINE
[04/29 22:41:11.075] Version
[04/29 22:41:11.075] ComputerName MAIN
[04/29 22:41:11.075] LanGroup WORKGROUP
[04/29 22:41:11.075] CurrentUser SYSTEM
[04/29 22:41:11.075] UserPrincipalName
[04/29 22:41:11.075] LogFile H:\Program Files (x86)\Secunia\PSI\psialog.txt
[04/29 22:41:11.075] LogFileMax 2097152
[04/29 22:41:11.075] OptionMask 1024
[04/29 22:41:11.075] LastCheckIn 04/29/11 22:41:10
[04/29 22:41:11.075] NextInspection 04/29/11 22:23:03
[04/29 22:41:11.075] ServerTime 01/01/80 00:00:00
[04/29 22:41:11.075] Unknown name in invoke:notifyCheckin
[04/29 22:41:11.075] Unknown name in invoke:periodic

Post "RE: PSI Scanner not working" has been selected as an answer.
mogs RE: PSI Scanner not working
Expert Contributor 30th Apr, 2011 09:36
Score: 2265
Posts: 6,268
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Hello.
Have you checked thro all the following ? :-
http://secunia.com/vulnerability_scanning/personal...
Note the emboldened statement further down !
Open the control panel
Open Internet Options > Security tab. In Windows7/Vista you may need to click 'Network and Internet' to access the Internet Options
Select the Internet zone and click on the Custom Level button.
In Security Settings, go to the Scripting>Active Scripting option.
Make sure that Active Scripting is enabled (rather than Disabled or Prompted).
Press OK then Yes.
Back in the Security tab, select the Trusted sites zone and click on the Sites button.
Type in the following and press the Add button to add it to the Trusted Sites list:
https://*.secunia.com
Press Close, then OK.
Run the Secunia PSI again to view the scan results.

If this has still not fixed your problem, go back to the Internet Options, then go to Tools->Internet Options->Advanced->Security->Check for server certificate revocation.

The Secunia SSL certificate is signed by Thawte. If the Thawte site is not accessible from the computer, and if this option is selected, then the PSI will fail to connect to our site. So please remove the check at “Check for server certificate revocation". However, please understand that this means your computer would not notice if a site publisher revoked his/her certificate, which could indicate a theft or loss. If you are concerned about this, try the steps outlined below before this one to see if they solve the problem

If this has still not allowed you to open the PSI, please go to Start > Control Panel > Administrative Tools > Services and ensure that both the 'Secunia PSI Agent' and 'Secunia Update Agent' services are set to 'Started' under status and 'Automatic' under 'Startup type'

If that did not resolve the problem either, and you are using Windows XP, try these steps:

1) Go to where you installed the PSI (Probably C:\Program Files\Secunia\PSI, or C:\Program Files (x86) for 64-bit systems), right-click PSI.exe, click Properties, go to the Compatibility tab, and set a check at 'Turn off advanced text services for this program'

If that did not resolve the issue, then you can try

2) Go to Control Panel > Regional and language options > Languages Tab > Details > Advanced. From here, set a check at 'Turn off advanced text services' (Please note that this is a global setting unlike what is described in step 2).


Hope it helps.......regards,

--
Was this reply relevant?
+1
-1
WolverineSix RE: PSI Scanner not working
Member 2nd May, 2011 23:35
Score: 6
Posts: 4
User Since: 28th Apr 2011
System Score: N/A
Location: US
mogs I appreciate your help
Tried everything you mention but no luck .
I am stumped
Thanks
Was this reply relevant?
+0
-0
mogs RE: PSI Scanner not working
Expert Contributor 3rd May, 2011 09:46
Score: 2265
Posts: 6,268
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
The fact that you're getting to scan...2 to 7....seems to suggest that the settings are in order.....most often it's been the case that psi doesn't work at all if any one of them is not configured aright......and you are sure about the SSL certificate being signed by Thawte ?
Is that the IE9 RTW version you are running ?

Some Windows 7 users had problems with the older version not removing when installing psi....and being as you've installed/uninstalled a number of times....letting it detect and remove the previous version usually means that it clears up after itself. But maybe you used Revo ?

Have you run CHKDSK recently to verify consistancy of the Disk ?
You are sure too, of your firewall configurations (?)....tho' I had an instance once where they had to be reconfigured each time I installed psi....whereas normally they are retained.
I'm not the most tech.savvy on the forum...nevertheless hope the foregoing is of some help............

--
Was this reply relevant?
+1
-1
This user no longer exists RE: PSI Scanner not working
Member 3rd May, 2011 09:47
Hi,

Have you tried installing the latest version of the PSI?

You can download it from the link in my signature.
Was this reply relevant?
+0
-0
WolverineSix RE: PSI Scanner not working
Member 4th May, 2011 01:33
Score: 6
Posts: 4
User Since: 28th Apr 2011
System Score: N/A
Location: US
Well i finally tried turning off my fire wall and anti virus and secunia worked .
I turned them back on and no luck .
So i rechecked my Firewall and it somehow had the old settings for the old program and the old location ,Now i guess i just need to figure out whether its my firewall settings or my av settings that PSI doesnt like
I did try uninstalling but the built in uninstaller would not work ,it just hung this time when actvated.So i used the Windows programs and features to uninstall PSI it worked fine and then i followed the link Emil posted to make sure i had the latest version .I am going to turn off the firewall once more to make sure its the problem.Hmm Nope its not the Firewall now ill try without the AV program.

Thanks again mogs and Thanks Emil
Was this reply relevant?
+3
-0
WolverineSix RE: PSI Scanner not working
Member 4th May, 2011 02:16
Score: 6
Posts: 4
User Since: 28th Apr 2011
System Score: N/A
Location: US
Adjusting Kaspersky AV made Secunia work .
Just in case any one else has this problem i will try to put down exactly what i did .
(all of the below In Kaspersky AV)

Open web antivirus
then click settings
Open trusted URLs tab
Click add
Add the following in the box
https://*.secunia.com
Then click ok
Now click add again
Then add the following in the box
https://psi.secunia.com
Then click ok
Then click apply
Then click ok
Now you should be good to go with PSI

I had done all of the above before but when i reinstalled PSI all of the settings vanished
Thanks again mogs for reminding me to recheck my settings
Was this reply relevant?
+3
-0
mogs RE: PSI Scanner not working
Expert Contributor 4th May, 2011 06:30
Score: 2265
Posts: 6,268
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
@Wolverine

Just glad you managed to figure it out and get yourself sorted !
Remember that,
If the issue is now resolved ; as you are the originator of the thread, you have the option to close it, by selecting ACCEPT. This will lock the thread : preventing tag-on posts and reminder e mails.......good luck and regards......

--
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


Secunia is a member of FIRST Secunia is a member of EDUcause Secunia is a member of The Open Group Secunia is a member of FS-ISAC
 
Secunia © 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer
follow Secunia on Facebook follow Secunia on Twitter follow Secunia on LinkedIn follow Secunia on YouTube follow Secunia Xing follow Secunias RSS feed follow Secunia on Google+