Forum Thread: Error creating deployment package for discontinued product

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
CSI

This thread has been marked as locked.
banthony Error creating deployment package for discontinued product
Member 24th May, 2011 21:25
Ranking: 2
Posts: 15
User Since: 26th Feb, 2010
System Score: N/A
Location: US
We have K-Lite Codec Pack installed on some computers in our environment. Secunia has identified "Media Player Classic 6.x" as a discontinued product within the pack. The more recent versions of K-Lite have the new Media Player Classic - Home Cinema bundled. The solution here would be to install a newer version of K-Lite which would replace the older Media Player Classic. The problem is that CSI will not allow me to create a package for anything with a product version of "Product Discontinued".

The following information is written to the log file when I attempt to create the package:

[05/24 08:06:17.535] Failed to create update: : 1 , Cannot create installable rule, reason (e)
[05/24 08:06:17.536] Exception when creating update: : -2146823281 , Unable to set value of the property 'message': object is null or undefined

Another solution would be to correctly identify this a being bundled with the K-Lite Codec Pack installation instead of a standalone application.

The K-Lite version and installation path can be gathered from the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\KLCodecPack\

The installed components can be gather from:

(Older versions) HKEY_LOCAL_MACHINE\SOFTWARE\KLCodecPack\Components \
(Newer versions) HKEY_LOCAL_MACHINE\SOFTWARE\KLCodecPack\InstalledI tems\

No one has replied to this thread yet - be the first
This thread has been marked as locked.